summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:07:11 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:19:00 +0200
commitfc3bc4ecb9cc3664fc3cc6da5a7690c351f7ea43 (patch)
treec7a61898d877c55abfec02d43c1f91bc8b06691b /gnu/packages/bioinformatics.scm
parent9c29648a321f1da4d9ee83c06aac2406dd82e590 (diff)
gnu: proteinortho: Remove dependency on lapack.
* gnu/packages/bioinformatics.scm (proteinortho): Remove dependency on lapack. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 313b4f36c1..7861987704 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8673,7 +8673,9 @@ predicts the locations of structural units in the sequences.")
(substitute* "Makefile"
(("INSTALLDIR=.*")
(string-append
- "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n")))
+ "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n"))
+ (("-llapack -lblas")
+ "-lopenblas"))
#t))
(add-before 'install 'make-install-directory
;; The install directory is not created during 'make install'.
@@ -8697,7 +8699,6 @@ predicts the locations of structural units in the sequences.")
("perl" ,perl)
("python" ,python-wrapper)
("blast+" ,blast+)
- ("lapack" ,lapack)
("openblas" ,openblas)))
(native-inputs
(list which))