summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 23:43:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 23:43:19 +0100
commit825b3ca76367dc9b084eaf535fd7aafc95b3c8fa (patch)
treea44bf9a6eb376fd0e3ac4793f6733186715e2410 /gnu/packages/bioinformatics.scm
parent3aa60e4096e5a9e880c9545cd28ec4aab610753f (diff)
gnu: Add isolator.
* gnu/packages/bioinformatics.scm (isolator): New variable. Change-Id: I950baca5b6898576f358b3364b1fe541b3333298
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 95df728bc9..a1cc041caa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7635,6 +7635,49 @@ to measure the reproducibility of findings identified from replicate
experiments and provide highly stable thresholds based on reproducibility.")
(license license:gpl2+)))
+(define-public isolator
+ (let ((commit "24bafc0a102dce213bfc2b5b9744136ceadaba03")
+ (revision "1"))
+ (package
+ (name "isolator")
+ (version (git-version "0.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dcjones/isolator.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12mbcfqhiggcjvzizf2ff7b05z31i47njcyzcivpw5j74pfbr3dv"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no check target
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'fix-std
+ (lambda _
+ (substitute* '("src/summarize.cpp"
+ "src/shredder.cpp")
+ (("isnan") "std::isnan")
+ (("isinf") "std::isinf")))))))
+ (inputs
+ (list boost hdf5 zlib))
+ (home-page "https://github.com/dcjones/isolator")
+ (synopsis "Tools for the analysis of RNA-Seq experiments")
+ (description "Isolator analyzes RNA-Seq experiments. Isolator has a
+particular focus on producing stable, consistent estimates. It implements a
+full hierarchical Bayesian model of an entire RNA-Seq experiment. It saves
+all the samples generated by the sampler, which can be processed to compute
+posterior probabilities for arbitrarily complex questions, far beyond the
+confines of pairwise tests. It aggressively corrects for technical effects,
+such as random priming bias, GC-bias, 3' bias, and fragmentation effects.
+Compared to other MCMC approaches, it is exceedingly efficient, though
+generally slower than modern maximum likelihood approaches.")
+ (license license:expat))))
+
(define-public jellyfish
(package
(name "jellyfish")