summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-02-19 15:42:22 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-02-20 08:45:39 +0100
commit312a479f8fa499d19c69a33181e60bd30f561a89 (patch)
treed7cbb59436373d750c51089a45120e38a9eb81b7 /gnu/packages/bioinformatics.scm
parentf0c839eb8a7846ee7c545876a3bea8e6a9489ab1 (diff)
gnu: python-ega-download-client: Disable some tests.
* gnu/packages/bioinformatics.scm (python-ega-download-client)[arguments]: Disable tests that fail on big machines; use "--ignore" where appropriate. Change-Id: I010c3a0e7cb69184b72e8b13bad04ff2fd364f5a
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2f889f14e3..e0da4dd624 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2542,11 +2542,24 @@ Python.")
(arguments
(list
#:test-flags
- '(list "-k"
- ;; These tests fail because they require internet access.
- (string-append "not test_download.py"
- " and not test_htsget.py"
- " and not test_commands.py"))
+ '(list
+ ;; These tests fail because they require internet access.
+ "--ignore=tests/functional/test_download.py"
+ "--ignore=tests/functional/test_htsget.py"
+ "-k"
+ (string-append "not test_error_5xx"
+ " and not test_error_too_many_requests"
+ ;; Something's wrong here. On some powerful machines
+ ;; (but not on my laptop) these fail, and tests like
+ ;; test_file_is_saved_into_an_existing_directory_which_was_specified_by_the_user
+ ;; take a *very* long time to complete.
+ ;;
+ ;; It looks like "dataset_in_fire.download" takes an
+ ;; unusually long time on those machines. We disable
+ ;; tests that fail under these conditions.
+ " and not test_download_file"
+ " and not test_output_file_is_removed_if_md5_was_invalid"
+ " and not test_post_stats_if_download_succeeded"))
#:phases
'(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements