summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-09 13:14:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:36 +0100
commit3a58a3ef053558bf229530c1792de23ef2651c44 (patch)
tree5cf96dcfa1ed8dc61ee20623c439286ccfc2a719 /gnu/packages/bioinformatics.scm
parent5a7f7156a2aeae564db561e2e5d613083dae2b4a (diff)
gnu: cnvkit: Update to 0.9.10.
* gnu/packages/bioinformatics.scm (cnvkit): Update to 0.9.10. [arguments]: Remove. [inputs]: Add r-minimal. Change-Id: Iaa27fd3dddc507c7a955441f066d4b0e3b8f1757
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 953a886270..8ae2b249a9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17907,7 +17907,7 @@ polymorphisms) and indels with respect to a reference genome and more.")
(define-public cnvkit
(package
(name "cnvkit")
- (version "0.9.9")
+ (version "0.9.10")
(source
(origin
(method git-fetch)
@@ -17916,17 +17916,8 @@ polymorphisms) and indels with respect to a reference genome and more.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1q4l7jhr1k135an3n9aa9wsid5lk6fwxb0hcldrr6v6y76zi4gj1"))))
+ (base32 "0r303pqjg70zpxa564bavbfj99c6di0dafgqqwx2vh4vfsiif94q"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- ;; See upstream commit eee0f6eaec57d5c6e58142d661979f3aacc5f76a
- (add-after 'unpack 'compatibility
- (lambda _
- (substitute* "setup.py"
- (("'joblib.*") "")))))))
(propagated-inputs
(list python-biopython
python-future
@@ -17941,6 +17932,7 @@ polymorphisms) and indels with respect to a reference genome and more.")
python-scipy
;; R packages
r-dnacopy))
+ (inputs (list r-minimal)) ;for tests
(home-page "https://cnvkit.readthedocs.org/")
(synopsis "Copy number variant detection from targeted DNA sequencing")
(description