summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-04-23 13:25:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-06 11:26:54 +0200
commit64fcc49dc54b4fd55f4f6a9d2d126631f74e5144 (patch)
treead1f2b5ef1d03c3f84471e855547ac374322986b /gnu/packages/bioinformatics.scm
parent2c52bbd16d5e12f7c67e3d26c593af64365ed4ee (diff)
gnu: Add r-metadeconfoundr.
* gnu/packages/bioinformatics.scm (r-metadeconfoundr): New variable. Change-Id: I733fb464d2a3c7fd1335826be9f23e2610e6fd60
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3dff39e866..5775d01c8a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11890,6 +11890,47 @@ analysis of cell types, subtypes, transcriptional gradients,cell-cycle
variation, gene modules and their regulatory models and more.")
(license license:expat))))
+(define-public r-metadeconfoundr
+ ;; There are some relevant updates after the release of version 0.3.0.
+ (let ((commit "90aec0226c5128bfcbbc08903452eff460d21424")
+ (revision "1"))
+ (package
+ (name "r-metadeconfoundr")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TillBirkner/metadeconfoundR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkqar27p5qwq46xbxsw5x1pl50xbkgqiizw5bydlyhwb0ga2f3h"))))
+ (properties `((upstream-name . "metadeconfoundR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bigmemory
+ r-detectseparation
+ r-doparallel
+ r-dosnow
+ r-foreach
+ r-futile-logger
+ r-ggplot2
+ r-lme4
+ r-lmtest
+ r-reshape2
+ r-snow))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/TillBirkner/metadeconfoundR")
+ (synopsis "Check multiple covariates for potenial confounding effects")
+ (description
+ "This package detects naive associations between omics features and
+metadata in cross-sectional data-sets using non-parametric tests. In a second
+step, confounding effects between metadata associated to the same omics
+feature are detected and labeled using nested post-hoc model comparison tests.
+The generated output can be graphically summarized using the built-in plotting
+function.")
+ (license license:gpl2))))
+
(define-public r-sleuth
(package
(name "r-sleuth")