summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-03 11:45:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:18 +0200
commitd14d5147b1eb42c98591af96f05a872d9ea791ae (patch)
tree7b2f51161cc58e491058319b9a401e48a7f7bc80 /gnu/packages/bioinformatics.scm
parent317be75d1d70673d73f76df1dafd7fe873f365bd (diff)
gnu: python-bioframe: Update to 0.6.4.
* gnu/packages/bioinformatics.scm (python-bioframe): Update to 0.6.4. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase; add 'pre-check phase. Use #:test-flags to disable tests that require internet access. [native-inputs]: Add python-hatchling. [propagated-inputs]: Add python-pyyaml. Change-Id: Iad1c8c6ef8f52886e398e9c4d2d384c5fce075c6
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dff8ba4d87..946898d055 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2857,7 +2857,7 @@ telomerecat can produce an estimate in ~1 hour.")
(define-public python-bioframe
(package
(name "python-bioframe")
- (version "0.3.3")
+ (version "0.6.4")
(source
(origin
(method git-fetch)
@@ -2868,18 +2868,21 @@ telomerecat can produce an estimate in ~1 hour.")
(file-name (git-file-name name version))
(sha256
(base32
- "14lvb18d4npapyi6j2zqh9q94l658dzmka5riiizw1h0zb0kp9xb"))))
- (build-system python-build-system)
+ "1m99hgxw4cb2x4qszb2lhp1isz57sdkqbmcgisnbqxqxkv4gba7v"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (setenv "MPLCONFIGDIR" "/tmp")
- (when tests?
- (invoke "pytest" "-v")))))))
+ (list
+ #:test-flags
+ '(list "-k" (string-append "not test_fetch_chromsizes"
+ " and not test_fetch_chromsizes_local_vs_ucsc"
+ " and not test_fetch_centromeres"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _ (setenv "MPLCONFIGDIR" "/tmp"))))))
(native-inputs
(list python-biopython
+ python-hatchling
python-pysam
python-pytest
python-wheel))
@@ -2887,6 +2890,7 @@ telomerecat can produce an estimate in ~1 hour.")
(list python-matplotlib
python-numpy
python-pandas
+ python-pyyaml
python-requests))
(home-page "https://github.com/open2c/bioframe")
(synopsis "Pandas utilities for tab-delimited and other genomic files")