summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHong.Li@mdc-berlin.de <Hong.Li@mdc-berlin.de>2022-10-25 13:42:36 +0000
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 15:03:21 +0200
commit358a1fdf7b388ed1047d82bf7522752b5bf29e18 (patch)
tree15932d33ee6db16fba9b9337284df1e9ed3087b2 /gnu/packages/bioinformatics.scm
parent87763421a9c2d194ac63e4c6ebe48b42d6b0e8f3 (diff)
gnu: Add r-seuratwrappers.
* gnu/packages/bioinformatics.scm (r-seuratwrappers): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 65feff9528..da57868284 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14211,6 +14211,44 @@ information... The package can also be used to extract data from @code{.loom}
files.")
(license license:expat))))
+(define-public r-seuratwrappers
+ ;; There are no releases or tags.
+ (let ((commit "d28512f804d5fe05e6d68900ca9221020d52cf1d")
+ (revision "1"))
+ (package
+ (name "r-seuratwrappers")
+ (version (git-version "0.3.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/satijalab/seurat-wrappers")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rm74y2fj3cmiqn7jz1ald8jbw53c2qxkj3mgl4pxih9vx39jhgy"))))
+ (properties `((upstream-name . "SeuratWrappers")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocmanager
+ r-cowplot
+ r-ggplot2
+ r-igraph
+ r-matrix
+ r-remotes
+ r-rlang
+ r-rsvd
+ r-r-utils
+ r-seurat))
+ (home-page "https://github.com/satijalab/seurat-wrappers")
+ (synopsis "Community-provided methods and extensions for the Seurat object")
+ (description
+ "SeuratWrappers is a collection of community-provided methods and
+extensions for Seurat, curated by the Satija Lab at NYGC. These methods
+comprise functionality not presently found in Seurat, and are able to be
+updated much more frequently.")
+ (license license:gpl3))))
+
(define-public python-ctxcore
(package
(name "python-ctxcore")