summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-05 13:47:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-05 13:47:57 +0200
commit3f627bf56bfc6c1904cfea4c73d0a5afc72b25ee (patch)
tree65823000c976d37ce866f3a3fda78f787ed98de6 /gnu/packages/bioinformatics.scm
parent9ed65e6af77893b658a7159b091b5002892c2f95 (diff)
gnu: cd-hit: Update to 4.8.1.
* gnu/packages/bioinformatics.scm (cd-hit): Update to 4.8.1. [arguments]: Do not use quasiquote; remove trailing #T from build phases. [inputs]: Add zlib.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0404253193..bb1aeac3a3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2429,26 +2429,27 @@ are not included due to their size.")
(define-public cd-hit
(package
(name "cd-hit")
- (version "4.6.8")
+ (version "4.8.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/weizhongli/cdhit"
"/releases/download/V" version
"/cd-hit-v" version
- "-2017-0621-source.tar.gz"))
+ "-2019-0228.tar.gz"))
(sha256
(base32
- "1b4mwm2520ixjbw57sil20f9iixzw4bkdqqwgg1fc3pzm6rz4zmn"))))
+ "1phmfhgcpyfd6kj7jwzw976613lcpv1wc2pzfdfaxla062x2s5r6"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; there are no tests
- #:make-flags
- ;; Executables are copied directly to the PREFIX.
- ,#~(list (string-append "PREFIX=" #$output "/bin")
- ;; Support longer sequences (e.g. Pacbio sequences)
- "MAX_SEQ=60000000")
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:tests? #f ; there are no tests
+ #:make-flags
+ ;; Executables are copied directly to the PREFIX.
+ #~(list (string-append "PREFIX=" #$output "/bin")
+ ;; Support longer sequences (e.g. Pacbio sequences)
+ "MAX_SEQ=60000000")
+ #:phases
+ '(modify-phases %standard-phases
;; No "configure" script
(delete 'configure)
;; Remove sources of non-determinism
@@ -2458,15 +2459,13 @@ are not included due to their size.")
((" \\(built on \" __DATE__ \"\\)") ""))
(substitute* "cdhit-common.c++"
(("__DATE__") "\"0\"")
- (("\", %s, \" __TIME__ \"\\\\n\", date") ""))
- #t))
+ (("\", %s, \" __TIME__ \"\\\\n\", date") ""))))
;; The "install" target does not create the target directory.
(add-before 'install 'create-target-dir
(lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))
- #t)))))
+ (mkdir-p (string-append (assoc-ref outputs "out") "/bin")))))))
(inputs
- (list perl))
+ (list perl zlib))
(home-page "http://weizhongli-lab.org/cd-hit/")
(synopsis "Cluster and compare protein or nucleotide sequences")
(description