summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-05 15:43:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-05 15:43:36 +0200
commit1f1b20b8bec64b5297769d57db5cf4855b6b80e2 (patch)
tree1a8190a437f4750ad45f643e6532c938ebe0af13 /gnu/packages/bioinformatics.scm
parent66e40e00654b8a637f0373d80f9ebc3f0c815022 (diff)
gnu: Add bits.
* gnu/packages/bioinformatics.scm (bits): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 152ee22225..35bed0f76e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5539,6 +5539,52 @@ biology. EMBOSS also integrates a range of currently available packages and
tools for sequence analysis into a seamless whole.")
(license license:gpl2+)))
+(define-public bits
+ (let ((revision "1")
+ (commit "3cc4567896d9d6442923da944beb704750a08d2d"))
+ (package
+ (name "bits")
+ ;; The version is 2.13.0 even though no release archives have been
+ ;; published as yet.
+ (version (string-append "2.13.0-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arq5x/bits.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "17n2kffk4kmhivd8c98g2vr6y1s23vbg4sxlxs689wni66797hbs"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'remove-cuda
+ (lambda _
+ (substitute* "Makefile"
+ ((".*_cuda") "")
+ (("(bits_test_intersections) \\\\" _ match) match))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "bin" (string-append (assoc-ref outputs "out") "/bin"))
+ #t)))))
+ (inputs
+ `(("gsl" ,gsl)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/arq5x/bits")
+ (synopsis "Implementation of binary interval search algorithm")
+ (description "This package provides an implementation of the
+BITS (Binary Interval Search) algorithm, an approach to interval set
+intersection. It is especially suited for the comparison of diverse genomic
+datasets and the exploration of large datasets of genome
+intervals (e.g. genes, sequence alignments).")
+ (license license:gpl2))))
+
(define-public piranha
;; There is no release tarball for the latest version. The latest commit is
;; older than one year at the time of this writing.