summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-11 19:52:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-11 20:01:53 +0100
commit531afc8a892512487251a03be24d9833b86179f1 (patch)
treeb2ad836c285269a999e66fc93b3c159359464273 /gnu/packages/bioinformatics.scm
parentf2785bd657c55cd36f436b1f6ee1af5d72683162 (diff)
gnu: Add pigx-chipseq.
* gnu/packages/bioinformatics.scm (pigx-chipseq): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 14e2a0daac..50d3568987 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12725,3 +12725,69 @@ and a configuration file which describes the experiment. In addition to
quality control of the experiment, the pipeline produces a differential
expression report comparing samples in an easily configurable manner.")
(license license:gpl3+)))
+
+(define-public pigx-chipseq
+ (package
+ (name "pigx-chipseq")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx_chipseq/"
+ "releases/download/v" version
+ "/pigx_chipseq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jliwhifnjgl9x0z730bzpxswi2s84fyg5y8cagbyzpw509452f5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ ;; Make sure the executable finds all R modules.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/pigx-chipseq")
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
+ `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
+ #t)))))
+ (inputs
+ `(("r-minimal" ,r-minimal)
+ ("r-argparser" ,r-argparser)
+ ("r-chipseq" ,r-chipseq)
+ ("r-data-table" ,r-data-table)
+ ("r-genomation" ,r-genomation)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rcas" ,r-rcas)
+ ("r-stringr" ,r-stringr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-heatmaply" ,r-heatmaply)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-plotly" ,r-plotly)
+ ("python-wrapper" ,python-wrapper)
+ ("python-pyyaml" ,python-pyyaml)
+ ("snakemake" ,snakemake)
+ ("macs" ,macs)
+ ("multiqc" ,multiqc)
+ ("perl" ,perl)
+ ("ghc-pandoc" ,ghc-pandoc)
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
+ ("fastqc" ,fastqc)
+ ("bowtie" ,bowtie)
+ ("idr" ,idr)
+ ("snakemake" ,snakemake)
+ ("samtools" ,samtools)
+ ("bedtools" ,bedtools)
+ ("kentutils" ,kentutils)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Analysis pipeline for ChIP sequencing experiments")
+ (description "PiGX ChIPseq is an analysis pipeline for preprocessing, peak
+calling and reporting for ChIP sequencing experiments. It is easy to use and
+produces high quality reports. The inputs are reads files from the sequencing
+experiment, and a configuration file which describes the experiment. In
+addition to quality control of the experiment, the pipeline enables to set up
+multiple peak calling analysis and allows the generation of a UCSC track hub
+in an easily configurable manner.")
+ (license license:gpl3+)))