summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-31 12:37:05 +0800
committerBen Woodcroft <donttrustben@gmail.com>2017-08-31 12:37:05 +0800
commit0691851a64382090c6deb30b967217725bdaaad6 (patch)
tree863829e274ae2b949a0cf5f71ff94fe54d75beb5 /gnu/packages/bioinformatics.scm
parentc959e5a1dc266325b2e4986a18bd98d1e37900ac (diff)
gnu: bioinformatics: Work around more "dotless @INC" build failures.
* gnu/packages/bioinformatics.scm (ncbi-vdb, sra-tools)[arguments]: Add 'set-perl-search-path' phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e3729537bb..70418cd977 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4751,6 +4751,13 @@ simultaneously.")
#:tests? #f ; no "check" target
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-perl-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) "/setup:"
+ (getenv "PERL5LIB")))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -5056,6 +5063,13 @@ sequence itself can be retrieved from these databases.")
"/lib32")))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-perl-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) "/setup:"
+ (getenv "PERL5LIB")))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
;; The build system expects a directory containing the sources and