summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-01-28 22:24:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-28 22:24:51 +0100
commitc4a2cbeb06f2a4d56f98e682c2897a3167530f58 (patch)
treeee8e54db56d47699104734341263bfa1aedd7978 /gnu/packages/bioinformatics.scm
parentd889c96be4e0794a33d215d24eabe7e65c1d75b9 (diff)
gnu: Add r-demultiplex.
* gnu/packages/bioinformatics.scm (r-demultiplex): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f536ae6004..161767c671 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016, 2018, 2019, 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -7269,6 +7269,45 @@ between two different types of motif instances using as much relevant
information as possible.")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-demultiplex
+ (let ((commit "6e2a1422c8e6f418cfb271997eebc91f9195f299")
+ (revision "1"))
+ (package
+ (name "r-demultiplex")
+ (version (git-version "1.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chris-mcginnis-ucsf/MULTI-seq")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01kv88wp8vdaq07sjk0d3d1cb553mq1xqg0war81pgmg63bgi38w"))))
+ (properties `((upstream-name . "deMULTIplex")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-kernsmooth" ,r-kernsmooth)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rtsne" ,r-rtsne)
+ ("r-shortread" ,r-shortread)
+ ("r-stringdist" ,r-stringdist)))
+ (home-page "https://github.com/chris-mcginnis-ucsf/MULTI-seq")
+ (synopsis "MULTI-seq pre-processing and classification tools")
+ (description
+ "deMULTIplex is an R package for analyzing single-cell RNA sequencing
+data generated with the MULTI-seq sample multiplexing method. The package
+includes software to
+
+@enumerate
+@item Convert raw MULTI-seq sample barcode library FASTQs into a sample
+ barcode UMI count matrix, and
+@item Classify cell barcodes into sample barcode groups.
+@end enumerate
+")
+ (license license:cc0))))
+
(define-public r-genefilter
(package
(name "r-genefilter")