summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-11-21 10:37:34 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-14 08:00:10 +1000
commit6b6f7d6a0e809c09a0cae47bfe41f2d35f6cf75b (patch)
tree1f3db392f1224a5ef15cbcaf95377e439a059a89 /gnu/packages/bioinformatics.scm
parent3d84a99e73fdc1f7523d33c27a4329ec43b6dbc9 (diff)
gnu: orfm: Update to 0.5.3.
* gnu/packages/bioinformatics.scm (orfm): Update to 0.5.3. [native-inputs]: Add inputs required for tests. [description]: Add commas.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c6531d669f..a0b7864918 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2079,7 +2079,7 @@ that a read originated from a particular isoform.")
(define-public orfm
(package
(name "orfm")
- (version "0.4.1")
+ (version "0.5.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2087,12 +2087,16 @@ that a read originated from a particular isoform.")
version "/orfm-" version ".tar.gz"))
(sha256
(base32
- "05fmw145snk646ly076zby0fjav0k7ysbclck5d4s9pmgcfpijc2"))))
+ "0vb6d771gl4mix8bwx919x5ayy9pkj44n7ki336nz3rz2rx4c7gk"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
+ (native-inputs
+ `(("ruby-bio-commandeer" ,ruby-bio-commandeer)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby" ,ruby)))
(synopsis "Simple and not slow open reading frame (ORF) caller")
(description
- "An ORF caller finds stretches of DNA that when translated are not
+ "An ORF caller finds stretches of DNA that, when translated, are not
interrupted by stop codons. OrfM finds and prints these ORFs.")
(home-page "https://github.com/wwood/OrfM")
(license license:lgpl3+)))