summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-11 14:47:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-11 22:44:07 +0300
commit3e6fdd5f8ac8f308531192f1d537570d69ea038e (patch)
tree3f64b271def7f18cf7d85eca271c6f4d8fe3062b /gnu/packages/bioinformatics.scm
parentf2b4c18cd96a69e375d7d9b5ad1c09f8fc065571 (diff)
gnu: snap-aligner: Limit to x86_64.
* gnu/packages/bioinformatics.scm (snap-aligner)[supported-systems]: Add note explaining why we build for x86_64 only.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a633e93e85..b206f3344d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4395,6 +4395,11 @@ is one that takes arguments.")
"SNAP is a fast and accurate aligner for short DNA reads. It is
optimized for modern read lengths of 100 bases or higher, and takes advantage
of these reads to align data quickly through a hash-based indexing scheme.")
+ ;; 32-bit systems are not supported by the unpatched code.
+ ;; Following the bug reports https://github.com/amplab/snap/issues/68 and
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=812378 we see that
+ ;; systems without a lot of memory cannot make good use of this program.
+ (supported-systems '("x86_64-linux"))
(license license:asl2.0)))
(define-public sortmerna