summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-22 19:20:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-22 19:21:16 +0300
commit62d00095c2d20f4625189c7e5d642f66f65fd9d7 (patch)
treea341f1ecc85116eb5fb80d865013ae2db8b398b1 /gnu/packages/bioinformatics.scm
parenta143e1b877106b696e41add97db96901468f855b (diff)
gnu: prank: Allow building on 32-bit machines.
* gnu/packages/bioinformatics.scm (prank)[arguments]: Add a phase removing the '-m64' compiler flag.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b273d2c540..28d138855d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3529,6 +3529,12 @@ generated using the PacBio Iso-Seq protocol.")
(lambda _
(chdir "src")
#t))
+ (add-after 'unpack 'remove-m64-flag
+ ;; Prank will build with the correct 'bit-ness' without this flag
+ ;; and this allows building on 32-bit machines.
+ (lambda _ (substitute* "src/Makefile"
+ (("-m64") ""))
+ #t))
(delete 'configure)
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)