summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-17 16:51:28 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-21 17:21:26 +0100
commit9fba89e8298303a94e098489d6a6806dbf25533b (patch)
tree4791cfc7c6f727eff534b8c77b75992b7c3eb227 /gnu/packages/bioinformatics.scm
parent9e47f30b08c261e1b5b30640cf227a50ab14dca1 (diff)
gnu: Add r-acsnminer.
* gnu/packages/bioinformatics.scm (r-acsnminer): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 21b85db903..25630211d5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3140,6 +3140,32 @@ BLAST, KEGG, GenBank, MEDLINE and GO.")
;; (LGPLv2.1+) and scripts in samples (which have GPL2 and GPL2+)
(license (list license:ruby license:lgpl2.1+ license:gpl2+ ))))
+(define-public r-acsnminer
+ (package
+ (name "r-acsnminer")
+ (version "0.15.11")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ACSNMineR" version))
+ (sha256
+ (base32
+ "1dl4drhjyazwm9wxlm8yfppwvvj4h6jxwmz8kfw5bxpb3jdnsqvy"))))
+ (properties `((upstream-name . "ACSNMineR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)))
+ (home-page "http://cran.r-project.org/web/packages/ACSNMineR")
+ (synopsis "Gene enrichment analysis")
+ (description
+ "This package provides tools to compute and represent gene set enrichment
+or depletion from your data based on pre-saved maps from the @dfn{Atlas of
+Cancer Signalling Networks} (ACSN) or user imported maps. The gene set
+enrichment can be run with hypergeometric test or Fisher exact test, and can
+use multiple corrections. Visualization of data can be done either by
+barplots or heatmaps.")
+ (license license:gpl2+)))
+
(define-public r-qtl
(package
(name "r-qtl")