summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 15:23:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:02 +0100
commitb41a05ce497d5ecc682cf46ce61aa2215193f9f6 (patch)
treedf76eaccd4a00fd741a66394a2bcf73e18dd7680 /gnu/packages/bioinformatics.scm
parentd8013ee221bd599474340899ffb5974796091955 (diff)
gnu: Remove work-arounds for bug 20765 (ensure uncompressed eggs).
Bug 20765 is solved since we build all Python packages using option "--single-version-externally-managed". * gnu/packages/bioinformatics.scm (pbtranscript-tofu): Remove configure-flags. (pepr): remove phase "disable-egg-generation". * gnu/packages/pdf.scm (reportlab): Remove configure-flags. * gnu/packages/python.scm (python-sphinx-rtd-theme, python2-elib.intl, python-pkgconfig, python-pytest-pep8, python-pytest-flakes): Remove configure-flags. (python-pillow) remove phase "disable-egg-generation". (python-libarchive-c) Remove patching setup.cfg. * gnu/packages/statistics.scm (python-patsy): remove phase "prevent-generation-of-egg-archive". * gnu/packages/tls.scm (python-acme): remove phase "disable-egg-compression". * gnu/packages/tor.scm (onionshare): Remove configure-flags.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 481a2a3bcb..9872933693 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3563,11 +3563,6 @@ the phenotype as it models the data.")
(build-system python-build-system)
(arguments
`(#:python ,python-2
- ;; With standard flags, the install phase attempts to create a zip'd
- ;; egg file, and fails with an error: 'ZIP does not support timestamps
- ;; before 1980'
- #:configure-flags '("--single-version-externally-managed"
- "--record=pbtranscript-tofu.txt")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-directory
@@ -7576,19 +7571,7 @@ may optionally be provided to further inform the peak-calling process.")
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; python2 only
- #:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- ;; When setuptools is used a ".egg" archive is generated and
- ;; installed. This makes it hard to actually run PePr. This issue
- ;; has been reported upstream:
- ;; https://github.com/shawnzhangyx/PePr/issues/9
- (add-after 'unpack 'disable-egg-generation
- (lambda _
- (substitute* "setup.py"
- (("from setuptools import setup")
- "from distutils.core import setup"))
- #t)))))
+ #:tests? #f)) ; no tests included
(propagated-inputs
`(("python2-numpy" ,python2-numpy)
("python2-scipy" ,python2-scipy)