summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-23 13:38:43 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-07-09 08:00:34 +1000
commitec2a67de8813dc7ea31c9825c6dfe6f27ad86344 (patch)
tree5e1cc6ef927316c2a136ca6f9993f2d554f4c436 /gnu/packages/bioinformatics.scm
parentc11f79a49ee64800c44929ec072e9b1f8b0765d0 (diff)
gnu: Add python-dendropy.
* gnu/packages/bioinformatics.scm (python-dendropy, python2-dendropy): New variables. * gnu/packages/patches/python-dendropy-exclude-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 03e7584f54..23a4470d7a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1446,6 +1446,40 @@ accessing bigWig files.")
(native-inputs
`(("python-setuptools" ,python2-setuptools))))))
+(define-public python-dendropy
+ (package
+ (name "python-dendropy")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "DendroPy" version))
+ (sha256
+ (base32
+ "1jfz7gp18wph311w1yygbvjanb3n5mdqal439bb6myw41dwb5m63"))
+ ;; There are two known test failures that will be fixed in the next
+ ;; release after 4.1.0.
+ ;; https://github.com/jeetsukumaran/DendroPy/issues/48
+ (patches (search-patches
+ "python-dendropy-exclude-failing-tests.patch"))))
+ (build-system python-build-system)
+ (home-page "http://packages.python.org/DendroPy/")
+ (synopsis "Library for phylogenetics and phylogenetic computing")
+ (description
+ "DendroPy is a library for phylogenetics and phylogenetic computing: reading,
+writing, simulation, processing and manipulation of phylogenetic
+trees (phylogenies) and characters.")
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-dendropy))))))
+
+(define-public python2-dendropy
+ (let ((base (package-with-python2 (strip-python2-variant python-dendropy))))
+ (package
+ (inherit base)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
+
+
(define-public deeptools
(package
(name "deeptools")