summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:30:54 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:27:31 +0100
commitf3b98f4fec43c951a9e28c67561395992bf190a7 (patch)
treeabda762491df7d66f0f41332b20739ca41c22aa1 /gnu/packages/bioinformatics.scm
parent5d8549328483978bf04dd2c710ef6a06614d4776 (diff)
gnu: Remove python-setuptools and python2-setuptools from inputs (part 2)
This patch contains the changes where removing setuptools from the inputs affected some code-lines beside. * gnu/packages/admin.scm (ansible): Remove all [inputs], [native-inputs] and [propagated-inputs] where python-setuptools or python2-setuptools are the sole entries. Remove python-setuptools and python2-setuptools listed on a line by its own from [inputs], [native-inputs] and [propagated-inputs]. * gnu/packages/backup.scm (duplicity): Likewise. * gnu/packages/bioinformatics.scm (bamm, python2-pybedtools, python2-bx-python, python2-dendropy, python-pysam, python2-pysam, clipper, crossmap, cutadapt, deeptools, grit, idr, python2-warpedlmm, pbtranscript-tofu, seqmagick): Likewise. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/freedesktop.scm (python-pyxdg, python2-pyxdg): Likewise. * gnu/packages/lirc.scm (python2-lirc): Likewise. * gnu/packages/mp3.scm (eyed3): Likewise. * gnu/packages/nutrition.scm (gourmet): Likewise. * gnu/packages/openstack.scm (python-hacking, python2-hacking, python-os-testr, python2-os-testr, python-stevedore, python2-stevedore, python-tempest-lib, python2-tempest-lib, python-oslo.log, python2-oslo.log, python-keystoneclient, python2-keystoneclient): Likewise. * gnu/packages/password-utils.scm (assword): Likewise. * gnu/packages/python.scm (python-passlib, python2-passlib, python-babel, python2-babel, python-parse-type, python-pytest, python2-pytest, python-scripttest, python2-scripttest, python-testtools, python2-testtools, python-testscenarios, python2-testscenarios, python-subunit, python2-subunit, python-pbr-0.11, python-pbr, python2-pbr, python-testrepository, python2-testrepository, behave, python-wheel, python2-wheel, python-requests, python2-requests, python-jsonschema, python2-jsonschema, python-pyjwt, python2-pyjwt, python-virtualenv, python2-virtualenv, python-jinja2, python2-jinja2, python-joblib, python2-joblib, python-sphinx, python2-sphinx, python-feedgenerator, python2-feedgenerator, python-scikit-image, python2-scikit-image, python-redis, python2-redis, python2-fastlmm, python-numpydoc, python2-numpydoc, python-matplotlib, python2-matplotlib, python2-pysnptools, python-rpy2, python2-rpy2, python-pillow, python2-pillow, python-pycparser, python2-pycparser, python-cffi, python2-cffi, python-cairocffi, python2-cairocffi, python-drmaa, python2-drmaa, python-pathpy, python2-pathpy, python-simplegeneric, python2-simplegeneric, python-ipython, python2-ipython, python-apsw, python2-apsw, python-lxml, python2-lxml, python-networkx, python2-networkx, python-pyzmq, python2-pyzmq, python-mccabe, python2-mccabe, python-mccabe-0.2.1, python-flake8, python2-flake8, python-flake8-2.2.4, python-mistune, python2-mistune, python-ptyprocess, python2-ptyprocess, python-llfuse, python2-llfuse, python-webob, python2-webob, python-xlrd, python2-xlrd, python-tables, python2-tables, python-pip, python2-pip, python-libarchive-c, python2-libarchive-c, python-docopt, python2-docopt, python-pyrfc3339, python2-pyrfc3339, python-configobj, python2-configobj, python-clint, python2-clint, python-rply, python2-rply, python2-rpython, python-widgetsnbextension, python2-widgetsnbextension jupyter, python-jupyter-console, python2-jupyter-console, python-hy, python2-hy, python-urllib3, python2-urllib3, python-rsa, python2-rsa, python-tox, python2-tox, python2-hypothesis, python-paste, python2-paste, python-pastescript, python2-pastescript, python2-unicodecsv, python-pkgconfig, python2-pkgconfig, python2-rope, python-sqlparse, python2-sqlparse, python-gevent, python2-gevent, python-tabulate, python2-tabulate, python-arrow, python2-arrow, python-cleo, python2-cleo, python-fake-factory, python2-fake-factory, ptpython): Likewise. * gnu/packages/rdf.scm (python-rdflib, python2-rdflib): Likewise. * gnu/packages/terminals.scm (asciinema): Likewise. * gnu/packages/version-control.scm (git-annex-remote-hubic): Likewise. * gnu/packages/xdisorg.scm (arandr): Likewise.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm49
1 files changed, 17 insertions, 32 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8377e811db..e90281fb5f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -215,8 +215,7 @@ structure of the predicted RNA.")
("libtool" ,libtool)
("zlib" ,zlib)
("python-nose" ,python2-nose)
- ("python-pysam" ,python2-pysam)
- ("python-setuptools" ,python2-setuptools)))
+ ("python-pysam" ,python2-pysam)))
(inputs
`(("htslib" ,htslib)
("samtools" ,samtools)
@@ -530,8 +529,7 @@ intended to behave exactly the same as the original BWK awk.")
("samtools" ,samtools)))
(native-inputs
`(("python-pyyaml" ,python2-pyyaml)
- ("python-nose" ,python2-nose)
- ("python-setuptools" ,python2-setuptools)))
+ ("python-nose" ,python2-nose)))
(home-page "https://pythonhosted.org/pybedtools/")
(synopsis "Python wrapper for BEDtools programs")
(description
@@ -1342,8 +1340,7 @@ well as many of the command line options.")
`(("python-numpy" ,python2-numpy)
("zlib" ,zlib)))
(native-inputs
- `(("python-nose" ,python2-nose)
- ("python-setuptools" ,python2-setuptools)))
+ `(("python-nose" ,python2-nose)))
(home-page "http://bitbucket.org/james_taylor/bx-python/")
(synopsis "Tools for manipulating biological data")
(description
@@ -1407,7 +1404,6 @@ multiple sequence alignments.")
("zlib" ,zlib)))
(native-inputs
`(("python-cython" ,python-cython)
- ("python-setuptools" ,python-setuptools)
;; Dependencies below are are for tests only.
("samtools" ,samtools)
("bcftools" ,bcftools)
@@ -1583,9 +1579,8 @@ databases.")
("python-numpy" ,python2-numpy)
("python-scipy" ,python2-scipy)))
(native-inputs
- `(("python-mock" ,python2-mock) ; for tests
- ("python-pytz" ,python2-pytz) ; for tests
- ("python-setuptools" ,python2-setuptools)))
+ `(("python-mock" ,python2-mock) ; for tests
+ ("python-pytz" ,python2-pytz))) ; for tests
(home-page "https://github.com/YeoLab/clipper")
(synopsis "CLIP peak enrichment recognition")
(description
@@ -1758,8 +1753,7 @@ time.")
("zlib" ,zlib)))
(native-inputs
`(("python-cython" ,python2-cython)
- ("python-nose" ,python2-nose)
- ("python-setuptools" ,python2-setuptools)))
+ ("python-nose" ,python2-nose)))
(home-page "http://crossmap.sourceforge.net/")
(synopsis "Convert genome coordinates between assemblies")
(description
@@ -1857,8 +1851,7 @@ preparation protocols.")
(alist-delete 'check %standard-phases))))
(native-inputs
`(("python-cython" ,python-cython)
- ("python-nose" ,python-nose)
- ("python-setuptools" ,python-setuptools)))
+ ("python-nose" ,python-nose)))
(home-page "https://code.google.com/p/cutadapt/")
(synopsis "Remove adapter sequences from nucleotide sequencing reads")
(description
@@ -2000,8 +1993,7 @@ trees (phylogenies) and characters.")
;; There is currently a test failure that only happens on some
;; systems, and only using "setup.py test"
(lambda _ (zero? (system* "nosetests")))))))
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ("python2-nose" ,python2-nose)
+ (native-inputs `(("python2-nose" ,python2-nose)
,@(package-native-inputs base))))))
@@ -2029,9 +2021,8 @@ trees (phylogenies) and characters.")
("python-pysam" ,python2-pysam)
("python-pybigwig" ,python2-pybigwig)))
(native-inputs
- `(("python-mock" ,python2-mock) ;for tests
- ("python-pytz" ,python2-pytz) ;for tests
- ("python-setuptools" ,python2-setuptools)))
+ `(("python-mock" ,python2-mock) ;for tests
+ ("python-pytz" ,python2-pytz))) ;for tests
(home-page "https://github.com/fidelram/deepTools")
(synopsis "Tools for normalizing and visualizing deep-sequencing data")
(description
@@ -2687,8 +2678,7 @@ comment or quality sections.")
("python-pysam" ,python2-pysam)
("python-networkx" ,python2-networkx)))
(native-inputs
- `(("python-cython" ,python2-cython)
- ("python-setuptools" ,python2-setuptools)))
+ `(("python-cython" ,python2-cython)))
(home-page "http://grit-bio.org")
(synopsis "Tool for integrative analysis of RNA-seq type assays")
(description
@@ -2934,8 +2924,7 @@ data. It also provides the bgzip, htsfile, and tabix utilities.")
("python-numpy" ,python-numpy)
("python-matplotlib" ,python-matplotlib)))
(native-inputs
- `(("python-cython" ,python-cython)
- ("python-setuptools" ,python-setuptools)))
+ `(("python-cython" ,python-cython)))
(home-page "https://github.com/nboley/idr")
(synopsis "Tool to measure the irreproducible discovery rate (IDR)")
(description
@@ -3423,9 +3412,8 @@ linker_so='gcc -shared'); defines")))))
("python-scipy" ,python2-scipy)
("python-matplotlib" ,python2-matplotlib)))
(native-inputs
- `(("python-mock" ,python2-mock) ;for tests
- ("python-pytz" ,python2-pytz) ;for tests
- ("python-setuptools" ,python2-setuptools)))
+ `(("python-mock" ,python2-mock) ;for tests
+ ("python-pytz" ,python2-pytz))) ;for tests
(home-page "http://genes.mit.edu/burgelab/miso/index.html")
(synopsis "Mixture of Isoforms model for RNA-Seq isoform quantitation")
(description
@@ -3562,8 +3550,7 @@ files and writing bioinformatics applications.")
("python-pandas" ,python2-pandas)
("python-pysnptools" ,python2-pysnptools)))
(native-inputs
- `(("python-setuptools" ,python2-setuptools)
- ("python-mock" ,python2-mock)
+ `(("python-mock" ,python2-mock)
("python-nose" ,python2-nose)
("unzip" ,unzip)))
(home-page "https://github.com/PMBio/warpedLMM")
@@ -3625,8 +3612,7 @@ the phenotype as it models the data.")
("python-h5py" ,python2-h5py)))
(native-inputs
`(("python-cython" ,python2-cython)
- ("python-nose" ,python2-nose)
- ("python-setuptools" ,python2-setuptools)))
+ ("python-nose" ,python2-nose)))
(home-page "https://github.com/PacificBiosciences/cDNA_primer")
(synopsis "Analyze transcriptome data generated with the Iso-Seq protocol")
(description
@@ -4750,8 +4736,7 @@ bioinformatics file formats, sequence alignment, and more.")
;; should be removed.
`(("python-biopython" ,python2-biopython-1.66)))
(native-inputs
- `(("python-setuptools" ,python2-setuptools)
- ("python-nose" ,python2-nose)))
+ `(("python-nose" ,python2-nose)))
(home-page "http://github.com/fhcrc/seqmagick")
(synopsis "Tools for converting and modifying sequence files")
(description