summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-16 17:41:07 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-22 11:11:09 +0200
commitfe4c37c244c0fb786c135e2da62306dc90df5638 (patch)
treee2e4864dab950c7ecbade1c760c9e5d776dfb8f6 /gnu/packages/bioinformatics.scm
parent1e656049b01bdeb2370229641ef8e0def92b4f89 (diff)
gnu: Add MOSAIK.
* gnu/packages/bioinformatics.scm (mosaik): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 51e3df6d81..48edd56854 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2149,6 +2149,52 @@ viewer.")
(string-append bin "/samtools")))))
(delete 'patch-tests)))))))
+(define-public mosaik
+ (let ((commit "5c25216d"))
+ (package
+ (name "mosaik")
+ (version "2.2.30")
+ (source (origin
+ ;; There are no release tarballs nor tags.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wanpinglee/MOSAIK.git")
+ (commit commit)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "17gj3s07cm77r41z92awh0bim7w7q7fbn0sf5nkqmcm1vw052qgw"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _ (chdir "src") #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p bin)
+ (copy-recursively "../bin" bin)
+ #t))))))
+ (inputs
+ `(("perl" ,perl)
+ ("zlib" ,zlib)))
+ (home-page "https://code.google.com/p/mosaik-aligner/")
+ (synopsis "Map nucleotide sequence reads to reference genomes")
+ (description
+ "MOSAIK is a program for mapping second and third-generation sequencing
+reads to a reference genome. MOSAIK can align reads generated by all the
+major sequencing technologies, including Illumina, Applied Biosystems SOLiD,
+Roche 454, Ion Torrent and Pacific BioSciences SMRT.")
+ ;; MOSAIK is released under the GPLv2+ with the exception of third-party
+ ;; code released into the public domain:
+ ;; 1. fastlz by Ariya Hidayat - http://www.fastlz.org/
+ ;; 2. MD5 implementation - RSA Data Security, RFC 1321
+ (license (list license:gpl2+ license:public-domain)))))
+
(define-public ngs-sdk
(package
(name "ngs-sdk")