summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-18 12:07:39 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-21 17:22:16 +0100
commit78addcb0ebce8a387be6ec43192cce7490cba794 (patch)
tree943ee42d83d582ee277871ae1072e8ca488d4b51 /gnu/packages/bioinformatics.scm
parent7485129e4f01af93dc5aa53991d86e38c191407d (diff)
gnu: Add IRanges.
* gnu/packages/bioinformatics.scm (r-iranges): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0f10ee9a47..cbc83dd391 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3215,6 +3215,36 @@ In addition, a few low-level concrete subclasses of general interest (e.g.
S4Vectors package itself.")
(license license:artistic2.0)))
+(define-public r-iranges
+ (package
+ (name "r-iranges")
+ (version "2.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "IRanges" version))
+ (sha256
+ (base32
+ "00x0266sys1fc5ipa639y84p6m6mgspk2xb099vcwmd3w4hypj9d"))))
+ (properties
+ `((upstream-name . "IRanges")
+ (r-repository . bioconductor)))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "http://bioconductor.org/packages/IRanges")
+ (synopsis "Infrastructure for manipulating intervals on sequences")
+ (description
+ "This package provides efficient low-level and highly reusable S4 classes
+for storing ranges of integers, RLE vectors (Run-Length Encoding), and, more
+generally, data that can be organized sequentially (formally defined as
+@code{Vector} objects), as well as views on these @code{Vector} objects.
+Efficient list-like classes are also provided for storing big collections of
+instances of the basic classes. All classes in the package use consistent
+naming and share the same rich and consistent \"Vector API\" as much as
+possible.")
+ (license license:artistic2.0)))
+
(define-public r-qtl
(package
(name "r-qtl")