summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-03-29 14:58:15 +0200
committerLeo Famulari <leo@famulari.name>2018-03-30 10:48:01 -0400
commitfdc306879b388b08be63ead6209473c184daa1e0 (patch)
treea7e7e2e8f0fadaf0b49993d550416157af11c4a6 /gnu/packages/bioinformatics.scm
parent183ce9884924794677eefca78cf445ada5551260 (diff)
gnu: Add delly.
* gnu/packages/bioinformatics.scm (delly): New variable. * gnu/packages/patches/delly-use-system-libraries.patch: New file. * gnu/local.mk: Include delly-use-system-libraries.patch. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index af515c026e..66d5bd3707 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2030,6 +2030,53 @@ normalized and standardized files, multiple visualizations can be created to
identify enrichments with functional annotations of the genome.")
(license license:gpl3+)))
+(define-public delly
+ (package
+ (name "delly")
+ (version "0.7.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tobiasrausch/delly/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0dkwy3pyxmi6dhh1lpsr3698ri5sslw9qz67hfys0bz8dgrqwabj"))
+ (patches (search-patches "delly-use-system-libraries.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:make-flags '("PARALLEL=1") ; Allow parallel execution at run-time.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
+ (templates (string-append (assoc-ref %outputs "out")
+ "/share/delly/templates")))
+ (mkdir-p bin)
+ (mkdir-p templates)
+ (copy-recursively "excludeTemplates" templates)
+ (install-file "src/cov" bin)
+ (install-file "src/delly" bin)
+ (install-file "src/dpe" bin)))))))
+ (native-inputs
+ `(("python" ,python-2)))
+ (inputs
+ `(("boost" ,boost)
+ ("htslib" ,htslib)
+ ("zlib" ,zlib)
+ ("bzip2" ,bzip2)))
+ (home-page "https://github.com/tobiasrausch/delly")
+ (synopsis "Integrated structural variant prediction method")
+ (description "Delly is an integrated structural variant prediction method
+that can discover and genotype deletions, tandem duplications, inversions and
+translocations at single-nucleotide resolution in short-read massively parallel
+sequencing data. It uses paired-ends and split-reads to sensitively and
+accurately delineate genomic rearrangements throughout the genome.")
+ (license license:gpl3+)))
+
(define-public diamond
(package
(name "diamond")