summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-18 15:19:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-18 15:46:18 +0100
commit6aebf864a724184a7073982c2dff6db945a29579 (patch)
tree4adfd0b394d2c5b5e231e0f5cfa02ecc090ab1ee /gnu/packages/bioinformatics.scm
parent2472015c36f333657c5a223150e3e809f01ad1af (diff)
gnu: python-multivelo: Simplify with pyproject-build-system.
* gnu/packages/bioinformatics.scm (python-multivelo)[build-system]: Use pyproject-build-system. [arguments]: Remove custom 'build and 'install phases.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e8da00d805..1d3c5d6312 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10847,25 +10847,12 @@ API services.")
(sha256
(base32
"1b4qyngwagh5sc2ygyfqyirg63myzh1g1glk03a1ykxfii32cjlp"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:tests? #f ;pypi source does not contain tests
#:phases
#~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (for-each
- (lambda (wheel)
- (format #t wheel)
- (invoke "python" "-m" "pip" "install"
- wheel (string-append "--prefix=" #$output)))
- (find-files "dist" "\\.whl$"))))
(add-before 'sanity-check 'set-env
(lambda _
;; numba RuntimeError: cannot cache function 'rdist'