summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-09 17:37:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:07:22 +0100
commitc3e330cf36dcfe308bcd6d88e60934a5d349b509 (patch)
tree92f9cfeb3d73273bbcd2e8096fa53af89e30dccf /gnu/packages/bioinformatics.scm
parent6e9518e201396602e92f89712f15c90d274260fa (diff)
gnu: python-pygenometracks: Update to 3.5.
* gnu/packages/bioinformatics.scm (python-pygenometracks): Update to 3.5. [build-system]: Use pyproject-build-system. [arguments]: Quote phases instead of full list of arguments; remove trailing #T from build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82801e7eeb..e6a8789ea6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13466,25 +13466,25 @@ genomic scores), long range contacts and the visualization of viewpoints.")
(define-public python-pygenometracks
(package
(name "python-pygenometracks")
- (version "3.3")
+ (version "3.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyGenomeTracks" version))
(sha256
(base32
- "16laa0wnf4qn9fb9ych4w1vqhqwjss70v0y0f6wp4gwqfrlgac0f"))))
- (build-system python-build-system)
+ "1l7smg2gc1vm2181lzmdnywb11gp6s6z6j444dbsigv65car8z8p"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f ; there are none
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:tests? #f ;there are none
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
(substitute* "setup.py"
(("matplotlib ==3.1.1")
- "matplotlib >=3.1.1"))
- #t)))))
+ "matplotlib >=3.1.1")))))))
(propagated-inputs
(list python-future
python-gffutils