summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2023-11-03 13:05:29 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-11-03 14:10:13 +0100
commitc9361460dece1dbc3d2645ad3e5c79e85a2bf183 (patch)
tree320adc53f364ed37e9d380426cc93b0229471123 /gnu/packages/bioinformatics.scm
parent6ae8fd7aa7a843ea831b24b74c9d3f7ea3ff49a9 (diff)
gnu: Add r-miamiplot.
* gnu/packages/bioinformatics.scm (r-miamiplot): New variable. Change-Id: I41a3a951c6f1835800301e4c168eeeb0dd299f06 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3a4bcd093a..baa990970c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10665,6 +10665,40 @@ of transcriptional heterogeneity among single cells.")
;; See https://github.com/hms-dbmi/scde/issues/38
(license license:gpl2)))
+(define-public r-miamiplot
+ (let ((commit "beede9c5d6431b4d822aa42e064e01baeb5dd4a0")
+ (revision "1"))
+ (package
+ (name "r-miamiplot")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/juliedwhite/miamiplot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wxxk1lk9jbf0imf59qp302ffasvs84idinkvzirs3dw9w3589n9"))))
+ (properties `((upstream-name . "miamiplot")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-gridextra
+ r-magrittr
+ r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/juliedwhite/miamiplot")
+ (synopsis "Create a ggplot2 miami plot")
+ (description
+ "This package generates a Miami plot with centered chromosome labels.
+The output is a ggplot2 object. Users can specify which data they want
+plotted on top vs. bottom, whether to display significance line(s), what
+colors to give chromosomes, and what points to label.")
+ (license license:gpl2))))
+
(define-public r-millefy
(package
(name "r-millefy")