summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 16:57:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 17:15:08 -0400
commit3bacd3c76a58ebe70f98be654f09cbd4166093ab (patch)
tree89f687565205971a9925d33400235968a569a069 /gnu/packages/bioinformatics.scm
parentdf3391c0309443ac37f9a9a6b1038a85454b8ee6 (diff)
parent97ed675718b948319e6f6e51f2d577971bea1176 (diff)
Merge branch 'master' into core-updates.
Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm135
1 files changed, 133 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f157523a76..cb12eba7c5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3521,8 +3521,6 @@ annotations of the genome.")
;; remainder of the code is licensed under the MIT license.
(license (list license:bsd-3 license:expat))))
-(define-deprecated deeptools python-deeptools)
-
(define-public cutadapt
(package
(name "cutadapt")
@@ -13991,6 +13989,85 @@ cells with similar identification cards in the different cytometric profiles
is then merged.")
(license license:gpl2))))
+(define-public r-cytoexplorer
+ (let ((commit "0efb1cc19fc701ae03905cf1b8484c1dfeb387df")
+ (revision "1"))
+ (package
+ (name "r-cytoexplorer")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DillonHammill/CytoExploreR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y7dadsy15i47rjmdq6ns80jzm6p0zmixll37q68ba2c7xn5pq3v"))
+ (snippet
+ '(delete-file
+ "docs/articles/CytoExploreR_files/vis-4.20.1/vis.min.js"))))
+ (properties `((upstream-name . "CytoExploreR")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'process-javascript
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs/articles/CytoExploreR_files/"
+ (let ((source (search-input-file inputs "/dist/vis.js"))
+ (target "vis-4.20.1/vis.min.js"))
+ (invoke "esbuild" source "--minify"
+ (string-append "--outfile=" target)))))))))
+ (propagated-inputs
+ (list r-biocgenerics
+ r-bslib
+ r-data-table
+ r-dplyr
+ r-embedsom
+ r-flowai
+ r-flowcore
+ r-flowworkspace
+ r-gtools
+ r-magrittr
+ r-mass
+ r-opencyto
+ r-purrr
+ r-rhandsontable
+ r-robustbase
+ r-rsvd
+ r-rtsne
+ r-shiny
+ r-superheat
+ r-tibble
+ r-tidyr
+ r-umap
+ r-visnetwork))
+ (native-inputs
+ `(("esbuild" ,esbuild)
+ ("r-knitr" ,r-knitr)
+ ("js-vis"
+ ,(let ((version "4.20.1"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/almende/vis")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "js-vis" version))
+ (sha256
+ (base32
+ "09ldcqzzki5c0jlwas5992qjffqxnx6j5sl703qccfw7rg1hn469")))))))
+ (home-page "https://github.com/DillonHammill/CytoExploreR")
+ (synopsis "Interactive analysis of cytometry data")
+ (description
+ "This package has been developed under ROpenSci gudelines to integrate
+conventional and cutting edge cytometry analysis tools under a unified
+framework. It aims to represent an intuitive and interactive approach to
+analysing cytometry data in R.")
+ (license license:gpl2))))
+
(define-public r-giotto
(let ((commit "3c8067cedbf6e3112edcac2ae796de05fd9d6fe4")
(revision "1"))
@@ -14049,6 +14126,60 @@ is then merged.")
spatial single-cell expression data.")
(license license:expat))))
+(define-public r-illuminahumanmethylationepicanno-ilm10b5-hg38
+ (let ((commit "3db06910e27f626e0cc8b335ff45cf9a4050a36a")
+ (revision "1"))
+ (package
+ (name "r-illuminahumanmethylationepicanno-ilm10b5-hg38")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/achilleasNP/IlluminaHumanMethylationEPICanno.ilm10b5.hg38")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y8fhiwmkldi57f8nq64njfgljw68cm6pb1vh44hjwcc12k48sqr"))))
+ (properties `((upstream-name . "IlluminaHumanMethylationEPICanno.ilm10b5.hg38")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-minfi))
+ (home-page
+ "https://github.com/achilleasNP/IlluminaHumanMethylationEPICanno.ilm10b5.hg38")
+ (synopsis "Illumina Human Methylation EPIC Annotation version 1.0B5")
+ (description
+ "This package provides a companion annotation file to the
+@code{IlluminaHumanMethylationEPICmanifest} package based on the same
+annotation 1.0B5.")
+ (license license:artistic2.0))))
+
+(define-public r-maxprobes
+ (let ((commit "c2120dba972e12115280ef274ff80550cee5b264")
+ (revision "1"))
+ (package
+ (name "r-maxprobes")
+ (version (git-version "0.0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markgene/maxprobes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kij9bds2l9mwm519bzyd2608563qjlmbrayhva1s0vgml5iq9wh"))))
+ (properties `((upstream-name . "maxprobes")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-minfi r-minfidata))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/markgene/maxprobes")
+ (synopsis "Methylation array cross-reactive probes")
+ (description
+ "The Maxprobes package collects cross-reactive probes of Illumina
+methylation array 450K and EPIC/850K.")
+ (license license:gpl2+))))
+
(define-public gffread
;; We cannot use the tagged release because it is not in sync with gclib.
;; See https://github.com/gpertea/gffread/issues/26