summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-30 15:16:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-30 15:16:34 +0300
commit7e1d02d53c1dd8d33df22744b44aa45ab10eb451 (patch)
tree42d8cc24688d7d6ca8929d6578c3d7f9e60fbe52 /gnu/packages/bittorrent.scm
parent5eaf5c90640330fc517b7f3f84e9ec4f823f794e (diff)
gnu: deluge: Use librsvg-for-system.
* gnu/packages/bittorent.scm (deluge)[native-inputs]: Replace librsvg input logic with librsvg-for-system.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 06d4b25a57..560b6155fa 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
@@ -525,9 +525,7 @@ features.")
python-zope-interface))
(native-inputs
(list intltool python-wheel
- (if (string-prefix? "x86_64-" (%current-system))
- librsvg
- librsvg-2.40)))
+ (librsvg-for-system)))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
;; started, some of the tests still fail. There are likely some tests