summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2023-12-07 16:02:15 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-14 23:12:23 +0100
commita1347d09f12ed315507e5c0b8644ba1eb350eca7 (patch)
tree34735d1b4d9e7ed0c965a92c064ca65be72a5bf2 /gnu/packages/bittorrent.scm
parent866274153195511a29251de902b964bbbbf46e57 (diff)
gnu: libtorrent-rasterbar: Disable test_ssl test.
It times out in the ci.guix.gnu.org, so this commit disables it. It will be re-enabled once solution is found. * gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]<#:phases>['check]: Disable test_ssl test. Change-Id: Ib396fd8a1786e14baad72ae892bdd0fd3fe7a180 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 731c8e1c20..8c032940d4 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -488,12 +488,16 @@ and will take advantage of multiple processor cores where possible.")
;; test_fast_extension, test_privacy and test_resolve_links
;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
;; execute only test_ssl under faketime.
- (invoke "faketime" "2022-10-24"
- "ctest"
- "-R" "^test_ssl$"
- "-j" jobs
- "--timeout" timeout
- "--output-on-failure"))))))))
+ ;;
+ ;; Note: The test_ssl test times out in the ci.
+ ;; Temporarily disable it until that is resolved.
+ ;; (invoke "faketime" "2022-10-24"
+ ;; "ctest"
+ ;; "-R" "^test_ssl$"
+ ;; "-j" jobs
+ ;; "--timeout" timeout
+ ;; "--output-on-failure")
+ )))))))
(inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python-wrapper" ,python-wrapper)