summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-02-08 15:46:10 +0800
committerChristopher Baines <mail@cbaines.net>2023-02-11 20:34:23 +0000
commitb1cca2126408948e3187f8664711c90892edcb23 (patch)
tree9d7e3e62e3b9f191796df1cc69de300020095a9f /gnu/packages/bittorrent.scm
parent7fbdb403d9c0374630da43fffd20cc7df0d734a1 (diff)
gnu: libtorrent-rasterbar: Update to 1.2.18.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.2.18. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index db5237c997..c3257cf2bf 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -385,7 +385,7 @@ and will take advantage of multiple processor cores where possible.")
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "1.2.15")
+ (version "1.2.18")
(source
(origin
(method url-fetch)
@@ -394,7 +394,7 @@ and will take advantage of multiple processor cores where possible.")
"releases/download/v" version "/"
"libtorrent-rasterbar-" version ".tar.gz"))
(sha256
- (base32 "0jr1c876mvwbbbnav8ldcdm1l6z3g404jc5wp8z902jcd0w8dbf8"))))
+ (base32 "0wpsaqadcicxl4lf1nc1i93c4yzjv8hpzhhrw1hdkrp4gn0vdwpy"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-Dpython-bindings=ON"
@@ -416,7 +416,7 @@ and will take advantage of multiple processor cores where possible.")
;; expiry date. To ensure succesful builds in the future,
;; fake the time to be roughly that of the release.
(setenv "FAKETIME_ONLY_CMDS" "test_ssl")
- (invoke "faketime" "2021-12-12"
+ (invoke "faketime" "2022-10-24"
"ctest"
"--exclude-regex" (string-join disabled-tests "|")
"-j" (if parallel-tests?