summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-18 03:58:23 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-18 03:58:23 +0100
commit256d5b3598fa2162e9712fc98781d2cb4ceda31e (patch)
tree0e7f7051a59aad879561b5c4ee885e24d3c04bc6 /gnu/packages/bittorrent.scm
parent9f6210cc5c114310a38ad1cc0ff5900409a7e7cc (diff)
parent1a9f267f51f97b8ca7049aa72763ddd64aad5b62 (diff)
Merge branch 'master' into wip-webkitwip-webkit
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 731c8e1c20..8c032940d4 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -488,12 +488,16 @@ and will take advantage of multiple processor cores where possible.")
;; test_fast_extension, test_privacy and test_resolve_links
;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
;; execute only test_ssl under faketime.
- (invoke "faketime" "2022-10-24"
- "ctest"
- "-R" "^test_ssl$"
- "-j" jobs
- "--timeout" timeout
- "--output-on-failure"))))))))
+ ;;
+ ;; Note: The test_ssl test times out in the ci.
+ ;; Temporarily disable it until that is resolved.
+ ;; (invoke "faketime" "2022-10-24"
+ ;; "ctest"
+ ;; "-R" "^test_ssl$"
+ ;; "-j" jobs
+ ;; "--timeout" timeout
+ ;; "--output-on-failure")
+ )))))))
(inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python-wrapper" ,python-wrapper)