summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-11-28 10:19:56 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-11-30 13:32:28 +0100
commitc5b2905d92e7c34616fca2dc12d9df991f2d7d06 (patch)
tree5277628a4858a99fa08748938354c6d52554b727 /gnu/packages/bootloaders.scm
parent8937abefb25d67e63e2a4271c5d75806be0d38b6 (diff)
gnu: dtc: Fix build on 32 bits platforms.
* gnu/packages/bootloaders.scm (dtc)[patches]: Add dtc-32-bits-check.patch and dtc-format-modifier.patch to fix build and tests on 32 bits platforms. * gnu/packages/patches/dtc-32-bits-check.patch : New file. * gnu/packages/patches/dtc-format-modifier.patch : New file. * gnu/local.mk (dist_patch_DATA): Add two above patches.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7d42ff3ebc..cee1b17019 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -302,7 +302,11 @@ menu to select one of the installed operating systems.")
"dtc-" version ".tar.xz"))
(sha256
(base32
- "08gnl39i4xy3dm8iqwlz2ygx0ml1bgc5kpiys5ll1wvah1j72b04"))))
+ "08gnl39i4xy3dm8iqwlz2ygx0ml1bgc5kpiys5ll1wvah1j72b04"))
+ ;; Fix build and tests on 32 bits platforms.
+ ;; Will probably be fixed in 1.4.6 release.
+ (patches (search-patches "dtc-format-modifier.patch"
+ "dtc-32-bits-check.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)