summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-28 15:17:38 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-28 15:25:03 +0100
commit52c0c82f52ff8dd8165b86fd53988fba39664d7e (patch)
tree0d9c2f04039bbe489b8c10a08f4224b40808a8fd /gnu/packages/bootstrap.scm
parent5c19dab94591db68c5361bc2521321fc587dc704 (diff)
gnu: bootstrap: Honor the origin's names.
Reported by Mark H Weaver <mhw@netris.org> at <https://lists.gnu.org/archive/html/guix-devel/2016-02/msg01100.html>. * gnu/packages/bootstrap.scm (bootstrap-origin)[boot]: Honor NAME.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index f5bf069c20..2cd8534ace 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -61,7 +61,7 @@
(define (boot fetch)
(lambda* (url hash-algo hash
#:optional name #:key system)
- (fetch url hash-algo hash
+ (fetch url hash-algo hash name
#:guile %bootstrap-guile
#:system system)))