summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-19 17:21:05 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-19 17:54:49 +0100
commit88854b1a4e364263b0d3c0d1e87de1ce7da51d34 (patch)
tree589bbb760cb6be114679e72906ae7a5325a692ce /gnu/packages/build-tools.scm
parent825c2c51748b8f0fc72d2511f1ea8f38a15d65d7 (diff)
gnu: gnulib: Refer to "gcc" as provided via implicit package inputs.
Fixes <https://issues.guix.gnu.org/60947>. Previously, with the #+(file-append gcc "/bin/gcc") reference, the resulting derivation would end up referring to the grafted GCC when grafts are enabled, and to the ungrafted one otherwise. As a result, a different derivation would be produced depending on whether grafts are enabled. * gnu/packages/build-tools.scm (gnulib-checkout)[arguments]: Refer to "gcc", not #+(file-append gcc "/bin/gcc").
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 5f6d0c6b4e..3d03c37a2c 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -929,7 +929,7 @@ Makefiles, JSON Compilation Database, and experimentally Ninja.")
(with-directory-excursion "lib"
;; See the compile-command buffer-local variable in
;; lib/gen-uni-tables.c
- (invoke #+(file-append gcc "/bin/gcc") "-O" "-Wall" "gen-uni-tables.c"
+ (invoke "gcc" "-O" "-Wall" "gen-uni-tables.c"
"-Iunictype" "-o" "gen-uni-tables")
(apply invoke
"./gen-uni-tables"