summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-06 11:31:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commit22c5d2d8350d0bc5445838c04a2e6546c6d4c9e0 (patch)
tree18fa6e5b04f752fc2cba7e545db4fe64b5ed7f8d /gnu/packages/build-tools.scm
parent08f48f29395ef9d3423c7e19047bf08bd55fe645 (diff)
gnu: meson-python: Update to 0.15.0.
* gnu/packages/build-tools.scm (meson-python): Update to 0.15.0. [arguments]: Add phase 'delete-directory. [propagated-inputs]: Add python-cython, python-pyproject-metadata-0.7, and python-typing-extensions. [native-inputs]: Add python-pytest-cov. Change-Id: I412af929c9e0485aa2a15e316d247f58e6f3477b
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 9e6ed6eec6..15d88ded80 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -346,13 +346,13 @@ resembles Python.")
(define-public meson-python
(package
(name "meson-python")
- (version "0.12.1")
+ (version "0.15.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "meson_python" version))
(sha256
(base32
- "1hpjw9qj6ff8ixjs0pz7qysc8v57jxgaf5n1p6bqm9bh3mc3wnrx"))))
+ "0vyjhjabvm41hqijifk33idbdl62i76kfyf884f9rs29rpp77nzx"))))
(build-system pyproject-build-system)
(arguments
;; The project is configured to use itself to build ('mesonpy') and fails;
@@ -361,13 +361,22 @@ resembles Python.")
#:test-flags #~(list "tests"
;; The test_pep518 tries to install
;; dependencies from the network using pip.
- "-k" "not test_pep518")))
+ "-k" "not test_pep518")
+ #:phases
+ '(modify-phases %standard-phases
+ ;; This additional top directory confuses setuptools. We could
+ ;; work around this by overriding the detection of the project
+ ;; directory, but deleting this directory is easier.
+ (add-after 'unpack 'delete-directory
+ (lambda _ (delete-file-recursively "LICENSES"))))))
(propagated-inputs
(list meson
ninja
python-colorama
- python-pyproject-metadata
+ python-cython
+ python-pyproject-metadata-0.7
python-tomli
+ python-typing-extensions
python-wheel))
(native-inputs
(list python-pypa-build
@@ -380,6 +389,7 @@ resembles Python.")
python-cython
python-gitpython
python-pytest
+ python-pytest-cov
python-pytest-mock))
(home-page "https://github.com/mesonbuild/meson-python")
(synopsis "Meson-based build backend for Python")