summaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:53:18 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit8ea7b6f91e42133181dc7d48df3f92bfa4bb67c3 (patch)
treeee97128bd6ebe4d7a6d4ddeab73c2ad2ea9c4d63 /gnu/packages/c.scm
parent1b518888638dce0c44192e8c0bbcb40752d162b4 (diff)
gnu: Add aws-c-io.
* gnu/packages/c.scm (aws-c-io): New variable. * gnu/packages/patches/aws-c-io-cmake-prefix.patch, gnu/packages/patches/aws-c-io-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c83e6f36e3..74c4b673a7 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -621,6 +621,37 @@ communication.")
(home-page "https://github.com/awslabs/aws-c-event-stream")
(license license:asl2.0)))
+(define-public aws-c-io
+ (package
+ (name "aws-c-io")
+ (version "0.9.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwyf1pm0hhcypyjc9xh9x7y50ic79xlbck1yf9d9wz0bnh43p7v"))
+ (patches
+ (search-patches
+ "aws-c-io-cmake-prefix.patch"
+ "aws-c-io-disable-networking-tests.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-cal" ,aws-c-cal)
+ ("aws-c-common" ,aws-c-common)
+ ("s2n" ,s2n)))
+ (synopsis "Event driven framework for implementing application protocols")
+ (description "This library provides a C99 framework for constructing
+event-driven, asynchronous network application protocols.")
+ (home-page "https://github.com/awslabs/aws-c-io")
+ (license license:asl2.0)))
+
(define-public aws-c-cal
(package
(name "aws-c-cal")