summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/calendar.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 45e5fba89b..c65db2b69e 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -36,6 +36,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages admin)
@@ -47,6 +48,7 @@
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -428,3 +430,38 @@ written in C++ using GTK. Launched once, it pops up a small calendar applet,
launched again it closes the running instance. It can additionally be
configured to show the current time in different timezones.")
(license license:bsd-3))))
+
+(define-public hebcal
+ (let ((commit "2384bb88dc1a41a4a5ae57a29fb58b2dd49a475d")
+ (revision "0"))
+ (package
+ (name "hebcal")
+ (version (git-version "5.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12rv3b51jb7wcjwmmizz9jkw7gh37yklys4xncvpzgxdkkfgmmjx"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hebcal/hebcal"))
+ (inputs
+ (list go-github-com-hebcal-hebcal-go
+ go-github-com-pborman-getopt))
+ (synopsis "Perpetual Jewish Calendar program")
+ (description
+ "Hebcal is a program for converting between Hebrew and Gregorian
+dates, and generating lists of Jewish holidays for a given year.
+Shabbat, holiday candle lighting, and havdalah times are approximated
+using your location.
+
+It can also show daily prayer times, the weekly Torah reading, and
+the daily leaf of Talmud. The program can help with counting of the
+Omer or with calculation of Hebrew yahrzeits, birthdays, or
+anniversaries.")
+ (home-page "https://github.com/hebcal/hebcal")
+ (license license:gpl2+))))