summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-18 21:44:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-18 21:44:04 +0300
commit726f2a944730a1edbdbebfe57fb9e7e0ba47d83e (patch)
tree0208efef238b150c05bb226ac66c5ef6b4c6f79b /gnu/packages/calendar.scm
parentf387f8f8ca707b5e9e670131125dc8b175e87b9a (diff)
gnu: khal: Update to 0.11.2.
* gnu/packages/calendar.scm (khal): Update to 0.11.2. [inputs]: Sort alphabetically.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index bffc965886..991995daf7 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2021 Stefan Reichoer <stefan@xsteve.at>
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -177,13 +177,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.11.1")
+ (version "0.11.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "07k0cfbfkx9fhfk4gf73vh34c05i1cb72gc15a1lmx9knxy4h503"))))
+ "1flrz01nsmvphiv673b8ia279qcp3gj6a1rsjlsj4gp5f69xif4g"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; The test suite is unreliable. See <https://bugs.gnu.org/44197>
@@ -202,17 +202,18 @@ data units.")
;; Required to build manpage
python-sphinxcontrib-newsfeed python-sphinx))
(inputs
- (list python-configobj
+ (list python-atomicwrites
+ python-click
+ python-click-log
+ python-configobj
python-dateutil
python-icalendar
+ python-pytz
+ python-pyxdg
python-tzlocal
python-urwid
- python-pytz
- python-setproctitle
- python-atomicwrites
- python-click
- python-click-log
- python-pyxdg))
+ ;; For the extras.
+ python-setproctitle))
(synopsis "Console calendar program")
(description "Khal is a standards based console calendar program,
able to synchronize with CalDAV servers through vdirsyncer. It includes