summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-23 22:21:00 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-23 22:21:00 +0200
commitd7ec2805fbb7fe39e2c66588baef0454aeb42548 (patch)
tree132e79661fd9b3c1dbe146537b00bd1412cb55cb /gnu/packages/calendar.scm
parent480a125bde4c1a568c2b1254136a00bc20a0e399 (diff)
parent74e96c4cb171b17949f638d8b452d047a8f2dc6f (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 7cd4911824..bffc965886 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -177,13 +177,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.10.5")
+ (version "0.11.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "0xhcrx7lcjk126i2xgqmgb199vd4hxsq34mkdmhdh9ia62nbgvsf"))))
+ "07k0cfbfkx9fhfk4gf73vh34c05i1cb72gc15a1lmx9knxy4h503"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; The test suite is unreliable. See <https://bugs.gnu.org/44197>
@@ -202,8 +202,7 @@ data units.")
;; Required to build manpage
python-sphinxcontrib-newsfeed python-sphinx))
(inputs
- (list sqlite
- python-configobj
+ (list python-configobj
python-dateutil
python-icalendar
python-tzlocal
@@ -216,7 +215,9 @@ data units.")
python-pyxdg))
(synopsis "Console calendar program")
(description "Khal is a standards based console calendar program,
-able to synchronize with CalDAV servers through vdirsyncer.")
+able to synchronize with CalDAV servers through vdirsyncer. It includes
+both a @acronym{CLI, command-line interface} and a @acronym{TUI, textual user
+interface} named 'ikhal'.")
(home-page "https://lostpackets.de/khal/")
(license license:expat)))