summaryrefslogtreecommitdiff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-30 12:01:32 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-30 12:05:27 +0200
commit79355ae3e84359716f5135cc7083e72246bc8bf9 (patch)
tree6b61851e2153581578bb78ef0f177b8841ee5db7 /gnu/packages/ccache.scm
parent39d6b9c99f297e14fc4f47f002be3d40556726be (diff)
parent86d8f6d3efb8300a3354735cbf06be6c01e23243 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 01db7ae57d..48ed860724 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -29,7 +29,7 @@
(define-public ccache
(package
(name "ccache")
- (version "3.2.5")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
@@ -37,24 +37,24 @@
version ".tar.xz"))
(sha256
(base32
- "11db1g109g0g5si0s50yd99ja5f8j4asxb081clvx78r9d9i2w0i"))))
+ "1ij1p8arz72fw67gx65ngb7jmg30ynjxk7i8dmikjxkdri4pmn66"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ;for test.sh
("which" ,(@ (gnu packages base) which))))
(inputs `(("zlib" ,zlib)))
(arguments
- '(#:phases (alist-cons-before
- 'check 'setup-tests
- (lambda _
- (substitute* '("test/test_hashutil.c" "test.sh")
- (("#!/bin/sh") (string-append "#!" (which "sh")))
- (("which") (which "which")))
- #t)
- %standard-phases)))
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'setup-tests
+ (lambda _
+ (substitute* '("test/test_hashutil.c" "test.sh")
+ (("#!/bin/sh") (string-append "#!" (which "sh")))
+ (("which") (which "which")))
+ #t)))))
(home-page "https://ccache.samba.org/")
(synopsis "Compiler cache")
(description
"Ccache is a compiler cache. It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
-again. Supported languages are C, C++, Objective-C and Objective-C++.")
+again. Supported languages are C, C++, Objective-C, Objective-C++, and
+Fortran 77.")
(license gpl3+)))