summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit7e9b6b7ee78eff87fbcee34512df18e7b4ee75cd (patch)
tree63db7124e6a83bca9ec81fe4468aeac7b21cd2ab /gnu/packages/cdrom.scm
parent56f954e30534559021d0b36b1dcda5633e5e6922 (diff)
gnu: asunder: Use G-expressions.
* gnu/packages/cdrom.scm (asunder)[arguments]: Rewrite as G-expressions and use THIS-PACKAGE-INPUT.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 130fffc127..de31002ac1 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -745,9 +745,10 @@ information is written to standard error.")
(base32 "0srpag9bca76iiv8766kxmbvhsri58k15xp70348frkvp7hy4s48"))))
(build-system glib-or-gtk-build-system)
(arguments
- '(#:out-of-source? #f
+ (list
+ #:out-of-source? #f
#:phases
- (modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(add-before 'check 'fix-tests
;; As of 3.0.1, there are no ‘real’ tests under src/, and the linty
;; test under po/ is broken. Still, it's trivial to fix.
@@ -756,19 +757,17 @@ information is written to standard error.")
(format file "~%src/upload.c~%")
(close-port file))))
(add-after 'install 'wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((program (string-append (assoc-ref outputs "out")
- "/bin/asunder")))
- (define (bin-directory input-name)
- (string-append (assoc-ref inputs input-name) "/bin"))
- (wrap-program program
- `("PATH" ":" prefix
- ,(map bin-directory (list "cdparanoia"
- "lame"
- "vorbis-tools"
- "flac"
- "opus-tools"
- "wavpack"))))))))))
+ (lambda _
+ (wrap-program (string-append #$output "/bin/asunder")
+ `("PATH" ":" prefix
+ ,(map (lambda (input) (string-append input "/bin"))
+ '#$(map (lambda (label) (this-package-input label))
+ (list "cdparanoia"
+ "flac"
+ "lame"
+ "opus-tools"
+ "vorbis-tools"
+ "wavpack"))))))))))
(native-inputs (list intltool pkg-config))
;; TODO: Add the necessary packages for Musepack encoding.
(inputs `(("gtk+-2" ,gtk+-2)