summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-06-18 17:42:25 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-06-18 17:42:25 +0800
commit2b91a30c5f9541b61d3ddec2b47bf4a69ddc148d (patch)
treef9d227cef8e3acc4aa3781e7a288f472c0f900dd /gnu/packages/check.scm
parent5f08b34578794fcb1909f104a73a945908e003d0 (diff)
gnu: guile-proba: Fix build.
* gnu/packages/check.scm (guile-proba)[arguments]: Don't refer to nonexistent 'install' phase. Change-Id: I2ef650c15f3f0d2640e746771667b20cfecb87ae
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 546ce1897e..7fc3f98d79 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3864,7 +3864,7 @@ markers to simplify testing of asynchronous tornado applications.")
(add-after 'build 'check
(lambda _
(invoke "guile" "proba.scm" "run" "tests")))
- (add-after 'install 'install-wrapped-script
+ (add-after 'check 'install-wrapped-script
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin-dir (string-append out "/bin"))
@@ -3876,7 +3876,7 @@ markers to simplify testing of asynchronous tornado applications.")
`("GUILE_LOAD_PATH" prefix (,(getenv "GUILE_LOAD_PATH")))
`("GUILE_LOAD_COMPILED_PATH" prefix
(,(getenv "GUILE_LOAD_COMPILED_PATH")))))))
- (add-after 'install 'install-manual
+ (add-after 'build-manual 'install-manual
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(info-dir (string-append out "/share/info")))