summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:49:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:49:25 +0300
commit970247e9f513d08ea0ceef6acef927345aa13a58 (patch)
tree29edf5f9a9aa034f3182c7fb5382b2c4c97e3c3b /gnu/packages/check.scm
parent2bde53c594aadca3df85d1011a41d8dfc183bb4b (diff)
gnu: python-lit: Update to 16.0.0.
* gnu/packages/check.scm (python-lit): Update to 16.0.0. [native-inputs]: Replace llvm with llvm-14.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 641f31a11b..550dc44d2d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2347,14 +2347,14 @@ programs, something like CSmith, a random generator of C programs.")
(define-public python-lit
(package
(name "python-lit")
- (version "14.0.3")
+ (version "16.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "lit" version))
(sha256
(base32
- "162x7pddwl395c3mdb0mfn3f5z24x1jz6g27x303lfxpzidnn4m4"))))
+ "04dyv8b2nbdbn61zdgm042a21dwidyapn9zbinlf879a29rc6jiw"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2363,7 +2363,7 @@ programs, something like CSmith, a random generator of C programs.")
(lambda _
(invoke "python" "lit.py" "tests"))))))
(native-inputs
- (list llvm))
+ (list llvm-14))
(home-page "https://llvm.org/")
(synopsis "LLVM Software Testing Tool")
(description "@code{lit} is a portable tool for executing LLVM and Clang