summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
committerMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
commit288b8fd5e97c32d44a49612dbeef854c05ebc373 (patch)
tree8a5021c9af2497c560ff94d37b8217d6187d8dbd /gnu/packages/check.scm
parenta7fb29866520d5661e0ac8e47957c91a2a43e11e (diff)
parentacff6aa00473befac75f8120fc4299f4f265c258 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 58cea4ae1b..8e1eb127b2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -144,6 +144,23 @@ unit testing. Test output is in XML for automatic testing and GUI based for
supervised tests.")
(license license:lgpl2.1))) ; no copyright notices. LGPL2.1 is in the tarball
+;; Some packages require this newer version of cppunit. However, it needs
+;; C++11 support, which is not enabled by default in our current GCC, and
+;; updating in-place would require adding CXXFLAGS to many dependent packages.
+;; Thus, keep as a separate variable for now.
+;; TODO: Remove this when our default GCC is updated to 6 or higher.
+(define-public cppunit-1.14
+ (package
+ (inherit cppunit)
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dev-www.libreoffice.org/src/"
+ "cppunit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1027cyfx5gsjkdkaf6c2wnjh68882grw8n672018cj3vs9lrhmix"))))))
+
(define-public catch-framework
(package
(name "catch")