summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 10:44:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 11:09:16 +0100
commit29f25f2929f2327c4eb102ec76df94df89b5070a (patch)
treef7eb1bf02686a98a43e4d2a0e45e5464d5935fc4 /gnu/packages/check.scm
parentc8ccf7c5c8bbd5e1ed09d39179d2e760a9f20d50 (diff)
gnu: python-pytest-warnings: Mark as superseded by python-pytest.
* gnu/packages/check.scm (python-pytest-warnings)[properties]: New field. (python2-pytest-warnings): Use PACKAGE-WITH-PYTHON2. [properties]: Superseded by PYTHON2-PYTEST.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f8d71ff797..59e644b948 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
@@ -1391,10 +1391,15 @@ recognize TestCases.")
(description
"Python-pytest-warnings is a pytest plugin to list Python warnings in
pytest report.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pytest-warnings))
+ ;; This package is part of pytest as of version 3.1.0.
+ (superseded . ,python-pytest)))))
(define-public python2-pytest-warnings
- (package-with-python2 python-pytest-warnings))
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-pytest-warnings)))
+ (properties `((superseded . ,python2-pytest)))))
(define-public python-pytest-capturelog
(package