summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-07 15:16:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-07 15:34:09 +0100
commitf7bd4f23723cf8985c4859945020c5e6cc772637 (patch)
treedebebcb37d7f1b4d30545d891a62fda4b095c449 /gnu/packages/check.scm
parent50c84dd5a653f99e9ac4cf058392125cdde93eb7 (diff)
gnu: python-pytest-mock: Update to 1.6.3.
* gnu/packages/check.scm (python-pytest-mock): Update to 1.6.3. [source]: Use tarball relase. [native-inputs]: Remove UNZIP. Add PYTHON-SETUPTOOLS-SCM.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1e2eabeba5..58cea4ae1b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -707,17 +707,17 @@ supports coverage of subprocesses.")
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
- (version "1.2")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytest-mock" version ".zip"))
+ (uri (pypi-uri "pytest-mock" version))
(sha256
(base32
- "03zxar5drzm7ksqyrwypjaza3cri6wqvpr6iam92djvg6znp32gp"))))
+ "075v7b2wm5f839r1a30n21wfk5rfqp3d05q7zb9jlb2wmxki23cj"))))
(build-system python-build-system)
(native-inputs
- `(("unzip" ,unzip)))
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/pytest-dev/pytest-mock/")