summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 10:59:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 11:09:17 +0100
commitc2f0e5a44b537632c2655f97a2539c3bf02c8a63 (patch)
tree9c33a5d36041c9d61cdc5b27d6177cd8aec6e43b /gnu/packages/check.scm
parent8b7009de7508b155a5554b8cd777446fc5a7e7d0 (diff)
gnu: python-rednose: Loosen six requirement.
* gnu/packages/check.scm (python-rednose)[arguments]: Add phase to remove explicit six version requirement.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 59e644b948..81fc1f6ffc 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1577,6 +1577,15 @@ JSON APIs with Behave.")
(base32
"11x5nx5b4wdq04s7vj1gcdl07jvvkfb37p0r5lg773gr5rr8mj6h"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.py
+ (lambda _
+ ;; Six is only required for tests and later versions
+ ;; work fine.
+ (substitute* "setup.py"
+ (("six==1.10.0") "six"))
+ #t)))))
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-termstyle" ,python-termstyle)))