summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-19 15:17:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-28 14:24:08 +0100
commitdfdf8d7477e37fd79b72da9a943b649278128337 (patch)
treebbab2c46b00084f0e82e1ec12f2100edd4b5a993 /gnu/packages/check.scm
parent667082d59104d4b964dce878f5e8c0f8ad1be958 (diff)
gnu: check: Update to 0.12.0.
* gnu/packages/check.scm (check): Update to 0.12.0. [source](uri): Update to new release URL. (check-0.11.0): Remove variable. * gnu/packages/xdisorg.scm (rofi)[native-inputs]: Replace CHECK-0.11.0 with CHECK.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7e713c6e86..4f24335d6b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -64,15 +64,15 @@
(define-public check
(package
(name "check")
- (version "0.10.0")
+ (version "0.12.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/libcheck/check/files/71408/"
- "/check-" version ".tar.gz"))
+ (uri (string-append "https://github.com/libcheck/check/releases/download/"
+ version "/check-" version ".tar.gz"))
(sha256
(base32
- "0lhhywf5nxl3dd0hdakra3aasl590756c9kmvyifb3vgm9k0gxgm"))))
+ "0d22h8xshmbpl9hba9ch3xj8vb9ybm5akpsbbh7yj07fic4h2hj6"))))
(build-system gnu-build-system)
(home-page "https://libcheck.github.io/check/")
(synopsis "Unit test framework for C")
@@ -85,20 +85,6 @@ faults or other signals. The output from unit tests can be used within
source code editors and IDEs.")
(license license:lgpl2.1+)))
-;; XXX: Some packages require this newer version. Incorporate this
-;; into the main 'check' package during the next rebuild cycle.
-(define-public check-0.11.0
- (package
- (inherit check)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libcheck/check/releases"
- "/download/" version "/check-" version ".tar.gz"))
- (sha256
- (base32
- "05jn1pgb7hqb937xky2147nnq3r4qy5wwr79rddpax3bms5a9xr4"))))))
-
(define-public cunit
(package
(name "cunit")