summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-03 12:53:38 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-03 12:57:40 +0200
commit28edab7a1ecc522a242d5366e226002ec2808aa1 (patch)
tree7cba86b62ab48f7418697c5a2b5cb5b60c84965d /gnu/packages/check.scm
parent2cdfe13deaf3d959e1ecb3a207cdbc28985e0e79 (diff)
gnu: cppunit: Explicitly link with libdl.
* gnu/packages/check.scm (cppunit)[arguments]: Add #:make-flags.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3e686cc743..5349ede0fa 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,12 +90,18 @@ with a flexible variety of user interfaces.")
(version "1.12.1")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/cppunit/" name "/"
+ (uri (string-append "mirror://sourceforge/cppunit/" name "/"
name "-"
version ".tar.gz"))
(sha256
(base32
"0jm49v5rmc5qw34vqs56gy8xja1dhci73bmh23cig4kcir6a0a5c"))))
+ ;; Explicitly link with libdl. This is expected to be done by packages
+ ;; relying on cppunit for their tests. However, not all of them do.
+ ;; If we added the linker flag to such packages, we would pollute all
+ ;; binaries, not only those used for testing.
+ (arguments
+ `(#:make-flags '("LDFLAGS=-ldl")))
(build-system gnu-build-system)
(home-page "http://sourceforge.net/projects/cppunit/")
(synopsis "Unit testing framework for C++")