summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:50:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:50:15 +0300
commit1be53ad1979a1c1da074d260adf376475250dc13 (patch)
tree1a7551f716a2861d44f5929f52cc7d93095a864f /gnu/packages/check.scm
parent970247e9f513d08ea0ceef6acef927345aa13a58 (diff)
gnu: python-lit: Honor the #:tests? flag.
* gnu/packages/check.scm (python-lit)[arguments]: Honor the #:tests? flag in the custom 'check phase.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 550dc44d2d..0ffd25e898 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2360,8 +2360,9 @@ programs, something like CSmith, a random generator of C programs.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "lit.py" "tests"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "lit.py" "tests")))))))
(native-inputs
(list llvm-14))
(home-page "https://llvm.org/")