summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 13:31:39 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit54b307a337550938b050918ecdf192612332bb7c (patch)
tree30dfa1421de18d67d3d3609f0ad76b73c5890fc4 /gnu/packages/check.scm
parent5f40f663f4b19ec2081def6813f499b54ea983bc (diff)
gnu: python-coverage: Update to 6.4.3.
* gnu/packages/check.scm (python-coverage): Update to 6.4.3. [propagated-inputs]: Add PYTHON-TOMLI.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7d131e55b5..5aecbd374b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1718,18 +1718,20 @@ have failed since the last commit or what tests are currently failing.")))
(define-public python-coverage
(package
(name "python-coverage")
- (version "5.2.1")
+ (version "6.4.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "coverage" version))
(sha256
(base32
- "16z8i18msgs8k74n73dj9x49wzkl0vk4vq8k5pl1bsj70y7b4k53"))))
+ "157vndwrzyv9ypn2w3b6g8gv7vw07v994hq8nxasdb75k3ry2apc"))))
(build-system python-build-system)
(arguments
;; FIXME: 95 tests failed, 539 passed, 6 skipped, 2 errors.
'(#:tests? #f))
+ (propagated-inputs
+ (list python-tomli))
(home-page "https://coverage.readthedocs.io")
(synopsis "Code coverage measurement for Python")
(description